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TOPICS

 CFBuilder: the free extension for the free VSCode editor

 Some common initial questions

 Installation (including on vscodium)

 Features and benefits

 VSCode features

 CFB basic features

 CFB configurability; features which require additional configuration (in CFB and/or CF)

 Comparison to other VSCode CFML extensions

 What they offer that CFBuilder does not; What CFBuilder offers that they do not

 Some more on CFB and VSCode

 Resources for finding more on both
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ME.ABOUT()

 I focus on CF server troubleshooting, as an independent consultant

 Assist organizations of all sizes, experience levels

 Work remotely 99% of the time, safe, secure, easy (via shared desktop)

 Solve most problems in less than an hour, teaching you also as we go

 Satisfaction guaranteed

 More on rates, approach, online calendar, etc at carehart.org/consulting

 But to be clear, I’m not selling anything in this session! ☺

 Again, slides for this talk available online:

 carehart.org/presentations
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AUDIENCES

 There are many different potential audiences for this talk:

 Those who love CFB and look forward to learning more

 Those who have heard of CFB on VSCode and want to learn more

 Those who knew of old Eclipse version, unaware of VSCode extension

 Those who have never heard of CFBuilder

 Those who have never heard of VSCode

 Those who use VSCode or CFB, as “a text editor” and expecting nothing more

 Those who get frustrated with not finding things they expect from other editors

 Those who have tried CFB on VSCode and hit problems

 Those familiar with other VSCode CFML extensions, who may fit in the above
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CFBUILDER: THE FREE ADOBE EXTENSION FOR 

THE FREE MS VISUAL STUDIO CODE EDITOR

 Before we go any further, let’s make a few points clear

 VSCode is free, open source, from Microsoft

 Formally “Visual Studio Code”, aka simply “code” (NOT Visual Studio)

 Huge marketplace of free extensions from the community and vendors

 By some estimates, VSCode used by most developers across most languages

 CFBuilder (aka “CFB”) is free, closed source, from Adobe

 Extension first released in July 2022; a few updates since then

 Original CFBuilder: commercial and closed source, based on Eclipse

 Last updated with CF2018, retired in 2024

 CFB on Vscode available for Windows, MacOS, Linux
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SOME COMMON INITIAL QUESTIONS

 What’s the relationship of VS Code to MS Visual Studio?

 Why did Adobe choose to leverage VSCode?

 What about existing CFML extensions for VSCode?

 Is there an available open source alternative? Yes: VSCodium (aka “codium”)

 What happened with Dreamweaver and CFStudio/HomeSite+?
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INSTALLING VSCODE & CFBUILDER

 Two key resources

 code.visualstudio.com/docs/setup/setup-overview

 helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-code/get-

started-coldfusion-builder-extension-visual-studio-code.html

 Note that CFB’s design requires Java be installed, JAVA_HOME env var defined

 More on this later

 Both tools are very simple, can start working with them within seconds (right now)

 But with both, there’s much you can learn to be more productive, as we will see!
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IMPLEMENTING CFB IN VSCODIUM

 Some folks are adamantly against MS licensing, not wanting MS telemetry, etc.

 VSCodium (vscodium.com) is built from same VSCode open source

 But no MS license (is permissive MIT license instead)

 No MS Telemetry

 FWIW, note that MS Telemetry can easily be DISABLED in VSCode

 No MS branding; lacking some MS-provided features

 VSCodium also uses its own marketplace (open-vsx.org): CFB not offered there

 But you CAN implement easily CFB within VSCodium…
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IMPLEMENTING CFB IN VSCODIUM 

(CONT.)

 You would use the VSCode feature to install an extension via its “vsix” file

 You can no longer obtain those from VSCode marketplace, but can either:

 Install CFB on VSCode and use “download vsix” under gear on all extension pages

 Downloading the extension at vsixhub.com/vsix/96583/

 Then in VSCodium, use “install from VSIX”, either:

 From Extensions tab, under its “…” (actions), choose “install from VSIX”

 Using Palette, type “install from VSIX”

 Point to the vsix downloaded above, then it’s installed instantly just like on VSCode
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FEATURES AND BENEFITS
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VSCODE FEATURES

 So many: code formatting, code folding, terminal, word wrap themes …

 File comparison, timeline, git integration, emmet expansion for html/css/more, AI, more…

 Could do literally for multiple talks on these alone

 I’ll point out at end resources for these and many more VScode capabilities

 Most available via either menus, buttons, keyboard shortcuts (configurable), or…

 Perhaps most important vscode tip: USE THE PALETTE!

 Access with View>Command Palette menu or ctrl-shift-p (or more simply F1) keystroke

 Start typing, to access world of feature possibilities

 Note that it remembers the most recently used ones at the top
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CFB BASIC FEATURES

 IntelliSense/Code assist 

 Cfml tags, functions, script statements appear as you start typing their name

 Can hit enter to select before completion (or use arrows to select)

 Hit space on tag to see popup description and attributes of tags, ctrl-space to see 

values

 Tag completion (closing tag offered after ending opening tag, where appropriate)

 Syntax help: mouse over a tag to see more help, and link to CF docs

 And still more …
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CFB BASIC FEATURES (CONT.)

 As well as: 

 Color coding

 Code formatting (that recognizes CFML, cfscript)

 Hover help

 Code navigation/outlining/folding

 Code insertion/wrapping (comments, dump, abort, as tags or script), #s, more

 Also supports these features for HTML, JavaScript, CSS

 And there are still more powerful features. More on them in a moment

 But what if you don’t like the choices Adobe made? …
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CONFIGURABILITY OF CFB

 On a CFM page, click “Profile Preferences” in lower right (or use palette: Profile 

Preferences)

 Can control tag closing, auto-quoting, indentation, white space insertion, wrapping, 

braces, and more

 Also offers profiles to save grouped settings

 Still a few other settings for the CFB extension: 

 Click Extensions in sidebar, right-click installed ColdFusion Builder extension 

 choose “settings” (also available by left-click of gear icon shown for extension)

 (Or use palette> @ext:com-adobe-coldfusion.adobe-cfml-lsp)

 …
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CONFIGURABILITY OF CFB (CONT.)

 Can also modify/view keyboard shortcuts for CFB features

 Use steps above but choose “keyboard shortcuts” instead of “settings” (for CFB)

 Shown over 80 CFB features/commands and their shortcuts 

 About 1/3 have shortcuts assigned: can change/remove

 Can add shortcuts to any of the rest

 Can also configure the shortcuts for hundreds of VSCode feature 

 (remove the search value shown at top, @ext:com-adobe-coldfusion.adobe-cfml-lsp)

 More on configurability of VSCode, later

 Several powerful CFB features require more than just “opening a CFM file”…
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CFB FEATURES THAT REQUIRE 

ADDITIONAL CONFIGURATION

 These include:

 Code refactoring, “quick fix” capabilities

 Security code analysis

 Code profiler (in association with CF PMT)

 Step debugging

 Server management

 RDS: Remote access for code, datasources, and more

 SQL building, editor

 Log viewer

 Services browser

 If this was a daylong workshop I’d demonstrate each, showing their power

 Again, other resources do that, which I offer in this talk

 Key: these need info in your CF server admin config, or the relationship of files (as “project”)…
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DEFINING A WORKSPACE, PROJECT

 Define a “project” holding your CF code, which requires first a “workspace”

 Workspace can technically be anywhere, just a folder where a file of metadata is put

 Project is the actual location of your CFML code

 That code can be anywhere, need NOT be in cf’s “wwwroot”

 But some features will only work if it’s a folder accessible by some URL in your browser

 helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-

code/project-manager.html

 I just learned that a coming update will remove requirement of a workspace

 Then some features require also rely on defining connection to a CF “server”…
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DEFINING A “SERVER”

 Under CF logo, configure a CF “server”, pointing to your CF instance

 Defining access to CF instance, local or remote (domain/ip, port, RDS password)

 If remote, your CFB machine must be able to reach that port of course

 helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-code/add-
coldfusion-builder-vscode-extension.html (that’s not a mistaken URL)

 Notice how this enables the RDS File View and RDS Dataview features

 Also empowers features where CFB needs CF config like datasources, mappings, etc.

 These are what require that the “project” be connected to a “server”

 Step debugging and security analyzer also require connection of “project” to “server”

 When pointing to Commandbox instance, may get “invalid server home” error 

 See my solution(s):

 community.ortussolutions.com/t/commandbox-visual-studio-code-adobe-coldfusion-
builder-extension-with-commandbox/9376/5 
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COMPARISON TO OTHER VSCODE 

CFML EXTENSIONS
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FAMILY TREE TIME:

SOME NEW, MOST ORPHANED

 Newer/currently updated

 CFMLEditor (cfmleditor.cfmleditor), from Gareth Eddies, forked from KamasamaK (below)

 Boxlang (ortus-solutions.vscode-boxlang), for boxlang (with cfml support as forked from Vadim below)

 Older/orphaned/no longer updated

 Vscode-cfml, from Vadim Sibiryanskiy, last updated in 2023, which was a fork of…

 Vscode-cfml, aka “CFML”, “Kamasamak” (kamasamak.vscode-cfml), last updated 2022, adapted from:

 vscode-coldfusion , aka “ColdFusion” (ilich8086.coldfusion), from Ilya Verbitskiy, last updated 2018

 ColdFusion, aka “Sketchpunk” (sketchpunk.coldfusion), last updated in 2015

 And more (note some are Lucee-only, like “CFML Formatter”)

 Beware judging them by “Install Count”, older ones naturally have larger values

 Note that VSCode default sort order is an undefined algorithm: not install count, rating, update date
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WHAT DID/DO OTHERS OFFER FOR CFML?

 Considering all those built from kamasamak, ilya, vadim, etc.

 Things they offer (which CFB does as well)

 Color coding, code formatting, hover help, code assist, snippets

 Ample (different) configurability of these things 

 Things they offer which CFB does not

 Linting (static code analysis, enforcing coding standards)

 Bundling CFLint extension (KamasamaK.vscode-cflint), which can be added to CFB

 Don’t require java like CFB, nor use of project or workspace like CFB does for some features

 And for many people, the above may seem “enough” to code CFML on VSCode

 Things CFB offers that they do not

 Recall those 10 features listed previously, which rely on defining a project, perhaps server
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MORE ON CFB AND VSCODE
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SOME FREQUENT CFB/VSCODE 

CHALLENGES

 Error: “Java version greater than 7 is required to run CFML extension"

 Must set JAVA_HOME env var

 helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-code/get-
started-coldfusion-builder-extension-visual-studio-code.html#install

 Again, some features won’t work unless CFB “project” is defined, others need “server”

 VSCode “Restricted mode”

 If you open a folder that vscode does not yet recognize, it will be in “restricted mode”

 CFB features won’t work because all extensions will be enabled or limited

 Can choose to “trust” (the authors of) the folder in question or its parent

 Other extensions may cause conflict

 Can “disable” for all of VSCode, or a specific workspace (no need to “uninstall”)

 …
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SOME FREQUENT CHALLENGES (CONT.)

 CFB sometimes forgets/does not preserve display of projects

 Only affects features that require that be configured, can “import” project definition

 VSCode features that may annoy you:

 “sticky scroll”: right-click when it appears, to disable

 “minimap” (on right): right-click and select “minimap” (to disable)

 AI/copilot feature popups: file>preferences>settings>disableai

 Beware: if you open a different folder (file>open folder), will be prompted to save 

unsaved tabs

 Doesn’t happen if you open just a file

 What if you don’t want to lose tabs? Can instead open a new window…
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SOME MORE VSCODE TIPS

 You can open a new window: File>New Window; then File>Open Folder

 Also, if that folder has no extensions associated with it yet, can choose to enable any

 Allows you to try different extensions (no need to “uninstall” one you don’t want)

 Can also open new window with new “profile” (giving it a name), and enable 

only some extensions

 Note when viewing files in file explorer (top left icon in vscode):

 If you single-click a file, it opens in a tab but does not STAY open if you click another

 If you double-click a file, it opens in a tab and stays open until you close it

 Like many modern editors, can close without saving text. Still there on re-open

 …
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SOME MORE VSCODE TIPS (CONT.)

 Can sync VSCode settings across machines (where you log in)

 Can opt out of VSCode collection of telemetry/usage data

 Can enable emmet text expansion for html, css, js

 To enable that within CFML files, add to vscode settings.json:

 "emmet.includeLanguages": {

  "cfml": "html"

 }

 And again really so much more I COULD point out
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WHAT ABOUT…?

 Snippets?

 File>Preferences>Configure Snippets

 Select “cfml.json”, see comments in the file for how to configure your own snippets

 Insert them using Command Palette: Snippets: Insert Snippets

 FTP?

 CFB offers no features for that, but extensions exist (consider SFTP, SSH, RDS)

 Wysiwyg html editing?

 VSCode does not offer that natively

 Configuring quick-access buttons?

 CFBuilder enables several actions on top right, not configurable it seems
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TO DIEHARD USER OF OLDER EDITORS

 I realize some have long stuck with older CFML editors

 DW: support for CF (and ASP, JSP) dropped in 2013, never updated for newer CFML

 CF Studio (dropped in 2001), HomeSite+ dropped in 2009

 Many still favor Notepad++, Sublime Text, others

 CFML support for them ended (2011 and 2012, respectively)

 Still, folks love how they open fast, are straightforward

 Still, each has their own ways of doing things (keystroke, Uis, snippets, etc.)

 Note that there are VSCode extensions to ease NP++, Sublime transition
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RESOLVING PROBLEMS

 Consider VSCode, CFB logs

 Open Palette (F1), then type Developer: Open Extension Logs Folder

 There have been 4 CFB updates (in 2025, 2024, and 2023)

 Can log bugs, feature requests in tracker.adobe.com

 select “ColdFusion Builder Extension for VSCode” as product

 Currently only 17 filed (just 5 from 2025); 11 marked “to fix”

 Seek help from community: cf411.com/cfsocialhelp

 Can email Adobe: cfsup@adobe.com

 Reach out to me directly, will help where I can (free or perhaps as consulting)
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WHAT IF YOU’RE STILL NOT SOLD ON CFB?

 I get it: some are happy with the CFML extension they use

 Or they’ve tried CFB and hit problems, and may still not be motivated to seek solution

 Maybe you just prefer older editors, whether they support CFML or not

 I’ll just note that you could just as readily use VSCode to edit CFML without CFB, etc.

 Even for both audiences, consider that you could STILL use CFB

 Such as to perform the CF Code Security Analyzer feature

 Or perhaps the PMT profiler feature, or even the CFML step debugger feature, etc.
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FINDING MORE INFO ON CFB

 See front page when extension is selected, offers reminders, doc links, or see:

 helpx.adobe.com/coldfusion/cfb-extension-vs-code-plugin-user-guide.html

 Many sections/docs below that (expand left nav bar). Let’s visit…

 Beware search engines/Ais/posts pointing to docs for OLD CFBuilder…

 Not:

 helpx.adobe.com/coldfusion/using-coldfusion-builder/managing-projects.html

 But:

 helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-code/project-

manager.html
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FINDING MORE INFO VSCODE

 Help>Open Walkthrough (also offers videos)

 Help>Editor Playground (guides)

 Help>Documentation (code.visualstudio.com/docs)

 Help>Keyboard Shortcuts Reference

 code.visualstudio.com/docs/getstarted/introvideos

 code.visualstudio.com/docs/getstarted/getting-started

 code.visualstudio.com/docs/getstarted/tips-and-tricks

 Many community resources: blog posts, videos, courses (LinkedinLearning, 
Udemy, etc.)
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FINALLY…

 I’ll add that I am contemplating creating an online course

 Send email to support@carehart.org, subject “course”, if interested to be notified

 Adobe has offered speakers a $25 gift card to giveaway

 I’ll offer it to the 5th person to send that email now ☺

 If time remains, some quick demos

 Otherwise, while we await emails, let’s move on to conclusion
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SUMMARY

 CFB is more than just Adobe’s extension: also all of VSCode (and its abilities)

 CFB adds many features that other CFML extensions don’t support (for better or worse)

 Ample resources exist to learn more about both CFB and VSCode

 Many concerns/complaints have been/can be resolved, or can reach out to Adobe

 Again, my contact info for follow-up:

 Charlie Arehart

 charlie@carehart.org

 @carehart (Slack, Github, X, FB, LinkedIn, etc.)

 Slides: carehart.org/presentations

 With that, hope you enjoyed the talk! 

 Use QR code for slide deck

 ...time for questions?
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